my PHP’s too old (or, something wrong with my Moodle!)

I’m trying to install Moodle on my newly formed server (newly online since 2017-08-20), but it shows a problem with my PHP installation.

Any ideas? Xibo states that my PHP may be too old because it doesn’t have php_fileinfo.dll included in its php.ini file.  It seems to me that I’d had Moodle up and running on this version (php-5.4.9-nts-Win32-VC9-x86) of PHP before.  Why not now?