now serving

The server is now … serving again.  It crashed a couple of weeks ago, and I’ve been trying to find a way to bring it back.

Disk failure.  An ongoing issue, I guess.  My HDDs are kind of old.
For a while, Windows could boot.  So I tried to clone it before it was too late.  It couldn’t clone because of disk errors.
I tried ‘chkdsk’ (part of Windows).  It fixed many errors.  After many reboots, many ‘chkdsk’s, and many cloning attempts, it eventually just wouldn’t boot.
I tried booting a cloned disk.  No go.  The clone didn’t take because it couldn’t complete the cloning process … because of disk errors.
I tried reinstating an image.  The image was no where to be found.
I eventually created a new Windows install on another disk and used it to read the old one so as to fix disk errors.  The new system could read the old disk.
Then, the new disk began making noise.  Drat.
So, another new install, this time on a RAID-1 disk array.  But then I couldn’t read my 3TB drive.  It only read 768GB.
At Caleb’s recommendation, I used Ubuntu Desktop to see if it could read the 3TB.  It couldn’t.  Old RAID system, I guess.
I tried to get the 3TB going in Windows again.  In this process, I lost my secondary backups on the 3TB drive.  Drat again.
New Windows install – Basic MBR disk again.  There’s the 3TB!  But no data.
Research – to find a way to copy my old MySQL database, inetpub webs, and everything else I need to resurrect the old webs.
It’s been a long time coming, but most webs are back up and running again.  Father’s web, lesjohnston.ca, is not yet working.  <sigh>  But I’ll stop here.

Headache from black mould in my house again.  I will leave the server be for now.